Upstream ISP Connectivity Issues (AS9498)
Resolved
May 23, 2026 at 6:29pm UTC
Maintenance ended
Affected services
Updated
May 21, 2026 at 5:35am UTC
We have identified the root cause of the issue and are actively working with our Upstream ISP. It would be resolved in next 1-2 business days. Thanks for your patience!
Affected services
Created
May 12, 2026 at 8:30am UTC
We are currently experiencing network instability due to issues with our upstream ISP provider, AS9498. This may cause intermittent connectivity problems or increased latency for some users. We are actively monitoring the situation and working with the provider to restore full service stability as quickly as possible.
Affected services